Netowrk Drive (Samba Share)

Use this forum to post questions and information specific to using AISBackup on Windows 7, Windows 8 and Windows 10.
Post Reply
rodscholl
Posts: 15
Joined: Tue Oct 30, 2007 2:58 pm
Location: MN, USA

Netowrk Drive (Samba Share)

Post by rodscholl » Thu Jun 20, 2013 10:02 pm

This *used* to work... but after reinstalling OS, I'm having trouble:

When backing up... For each file I get an ERROR 50:
Failed to backup network file: Check Access Rights or the file was Opened Exclusively: \\storm\scholl\blah-blahfilename [Error 50: The reqeust is not supported ]

That drive \\storm\scholl is mapped as s:\ on my vista machine via samba share.

The destination drive \\harrrier\iosafe is mapped as Q:\ on my vista machine via samba share.

Any Ideas? Been fighting this an hour at a time for a week now...

Thanks so much! LOVE the program, and have written articles about is features. Great control and awesome features.

Extra details:
Running AISBacup on Vista X64 Service Pack 2 with all critical updates.
I have disabled UAC
Windows Defender is Off
Windows Firewall is off
There is only one user account, scholl, which is an administrator account (I think).
The linux account name is also scholl and has the same password. They *might* be in different WORKGROUPs -- but I never understood the impact of those.
Remote machine is linux (Centos) that has an external drive (via USB).

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Accessing Samba shares

Post by Barry » Fri Jun 21, 2013 3:45 pm

Do backups from Windows work to \\harrrier\iosafe?

Do backups from \\storm\scholl work to a local disk on Windows (actually I guess not)?

Also: Do not backup up NTFS security setting from Linux as there aren't any - actually this may be the solution!! (Manage Backup / Change Backup Job Settings)

Here is a previous reply about mapping on Windows Vista, 7 and 8

This may be because the shares are mapped in your user account and AISBackup is running as an administrator, if so this may help:

Please download the latest version of AISBackup as some work has been done in the network part; however not specifically for this problem so the problem may persist.

If the problem is still there I would like you to try the following as the fault may be caused by UAC (non admin and admin mapping the same drive) here is the full article:

http://support.microsoft.com/kb/937624

and here is the salient point (Registry Edit):

Start /Search type RegEdit and press [ENTER]
navigate to HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ System then right click the right hand pane and choose New / DWORD (32-bit) Value

Name the entry EnableLinkedConnections
Then double click this entry and change the value from 0 to 1

Re-boot.

If this works I will build the option into the advanced settings of AISBackup as an option.

If this does not work you may remove the EnableLinkedConnections value (Right click / Delete).

=================================================

Barry

rodscholl
Posts: 15
Joined: Tue Oct 30, 2007 2:58 pm
Location: MN, USA

Post by rodscholl » Mon Jun 24, 2013 6:16 pm

Thanks, Barry. I'm trying some of those solutions...

Meanwhile, it may be informative to point out that the box to disable the NTFS security settings is greyed out for me (and checked).

Does that mean anything?

Rod

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

NTFS settings

Post by Barry » Mon Jun 24, 2013 6:36 pm

The NTFS settings box is disabled if there has been a backup run (even if nothing was backed up). Try resetting the backup then you should be able to disable the NTFS option (Manage Backup / Reset Backup).

If this works I will have to implement an automated work-around.

Barry

rodscholl
Posts: 15
Joined: Tue Oct 30, 2007 2:58 pm
Location: MN, USA

Post by rodscholl » Tue Jun 25, 2013 5:19 pm

that did it!

I did a reset, and then unchecked the NTFS settings.

Thanks Barry -- add "great support" to why AISBackup is the best archival tool ever.

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

All working?

Post by Barry » Tue Jun 25, 2013 5:56 pm

So is it all working now?

I guess it is.

Cheers

Barry

Post Reply