Vista x86: "Quietly" option for scheduled jobs doe

Use this forum to post questions and information specific to using AISBackup on Windows 7, Windows 8 and Windows 10.
Post Reply
BartK
Posts: 65
Joined: Tue May 17, 2005 11:17 am

Vista x86: "Quietly" option for scheduled jobs doe

Post by BartK » Fri Feb 08, 2008 9:15 pm

Barry,

The "Quietly abort if media not loaded (but only when scheduled)" option does not result in a termination of the scheduled job. A manual end is necessary.

I use a external drive which is not allways up. At that time the schedules may be bypassed.

With regards,

Bart Kamminga

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Abort if external drive not connected.

Post by Barry » Mon Feb 11, 2008 4:03 pm

Hi Bart

I just tested this, the command line parameters are:

"FW01 ME C|Q"

I just tested this to a disconnected external drive on Windows XP, however after two minutes the job terminated (the dialogue counts down 120 seconds). Did you want the job to terminate immediately if the 'Quietly abort' option is selected?

I ran the job under the current logged on user, and as another 'hidden' backup account.

The job must be of stype 'external drive backup' or AISBackup will display a 'cannot find backup' message, is this is what is happening?

Barry

BartK
Posts: 65
Joined: Tue May 17, 2005 11:17 am

Abort if external drive not connected

Post by BartK » Thu Feb 14, 2008 11:20 pm

Barry,

The task scheduler under Vista is a complete new design. Therefor I think that XP is not usable for testing.

I get the following e-mail (only one) after a long period: (although there are 8 schedules)

AISBackup job: Backup Installation Files Backup completed successfully

20:00:03 SSTART Backup Session 15 Auto Run: Started on dinsdag 12 februari 2008 at 20:00:03 Version: 2.5 (309)
20:00:03 INF Run Time Parameters: [QYYYYYYY]
20:00:03 INF User Account: Backup (AIS)
20:00:03 INF Running un-attended (non-interactively)
20:00:45 AUTORUN Queuing jobs: Backup Export Files
20:00:45 AUTORUN Queuing jobs: Backup Image Files
20:00:45 AUTORUN Queuing jobs: Backup Shared Files
20:00:45 AUTORUN Queuing jobs: Backup WinXPnl - Primary
20:00:45 AUTORUN Queuing jobs: Backup Vista1st (x86)
20:00:45 AUTORUN Queuing jobs: Backup Vista2nd (x64)
20:00:47 AUTORUN Already Queued: Backup Vista2nd (x64)
20:30:02 AUTORUN Already Queued: Backup Shared Files
21:00:02 AUTORUN Already Queued: Backup WinXPnl - Primary
21:30:02 AUTORUN Already Queued: Backup Vista1st (x86)
22:00:02 AUTORUN Already Queued: Backup Vista2nd (x64)
0:01:08 MSG The backup job has not been loaded
0:01:08 INF Creating Session: 1
0:01:08 SESSEND External drive [AISBACKUP] not connected
0:01:09 inf Preparing completion log

But: indeed I get the message "cannot find backup". Before every backup job I see a symbol (USB plug). Does this confirmed the stype?

Bart Kamminga

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Scheduled backup not terminating if drive not connected

Post by Barry » Fri Feb 15, 2008 2:43 pm

Please e-mail me the .buz files from these backup job so that I may attempt to duplicate (the first plus 2 other jobs should be enough).

Are all jobs scheduled for the same time?

If the drive is connected all these scheduled jobs work okay, yes?

Barry

BartK
Posts: 65
Joined: Tue May 17, 2005 11:17 am

Scheduled backup not terminating if drive not connected

Post by BartK » Fri Feb 15, 2008 6:47 pm

Barry,

The jobs are scheduled for each half hour from 18:00h until 22:00h. The jobs run well when the drive is connected. I send you this evening the .buz files.

Bart Kamminga

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Scheculed tasks problem: Drive not present

Post by Barry » Thu Feb 21, 2008 5:44 pm

Hi Bart

Another user had reported this problem and cannot recreate the problem after uploading a recent build. Please try the pre-release version (build 314 or higher) to see if this fixes the problem. I have put some more checks into AISBackup to try and prevent this error - however, it is difficult to test because the backup never hangs for me. I used all your job files for the test.

The only thing I can think of now is if Windows 'thinks' the disk is available, i.e. it still shows up in explorer after disconnection.

http://www.aiscl.co.uk/aisbackupbeta.php

Barry

BartK
Posts: 65
Joined: Tue May 17, 2005 11:17 am

Scheduled backup not terminating if drive not connected

Post by BartK » Sat Mar 01, 2008 6:11 pm

Barry,

I could see that you were testing on Sunday because I got all the output mailed.

I tested 3.14 on Vista x64 and the problem looks solved. With the backup drive disconnected all the jobs results in 0x0 and the following output:

AISBackup job: Backup xxx Files
Backup completed with errors
(External drive not connected)

16:33:50 SSTART Backup Session 40 Auto Run: Started on zaterdag 1 maart 2008 at 16:33:50 Version: 2.6 (314)
16:33:50 INF Run Time Parameters: [YYYYYYY]
16:33:50 INF User Account: Backup (AIS)
16:33:50 INF Running un-attended (non-interactively)
16:33:51 INF Creating Session: 40
16:33:51 SESSEND External drive(s) [AISBACKUP] not connected
16:33:51 inf Preparing completion log

I found a little thing in the Task Schedules definitions. Under Actions the Program/Script field is defined without quotes (") and results in a misinterpretation between program and argument(s). Answer "No" results in a corrected quoted field.

Bart Kamminga

Post Reply