Problems permanently excluding files from preview.

Pre-Release and beta version of AISBackup
Post Reply
Posts: 66
Joined: Fri May 13, 2005 11:35 am

Problems permanently excluding files from preview.

Post by IanA »

Thanks for the follow ups to previous bugs Barry, I'll post to the forum if poss. from now on...

Had a problem a couple of days ago which got into such a mess that I had to restart AISBackup as it failed part way through the file load in Modify Files & Folders List. Tried to recreate problems today and got following results...

Created a new job to backup 6 files in 1 folder.
Ran the job successfully.
Created copies of the 6 files within the same folder.

[Incidentally: At this stage, when I pressed preview I got warning that The backup is newer than indicated by the Backup Contents File. Replied YES to replace.]

Continued with preview and ticked the whole folder.
Chose to permanently exclude files. (I'm not sure what this is supposed to do at this stage - permanently exclude all the files in the folder selected, or only the files to be backed up in this session - this could be very confusing)

AISBackup rightly said there were no files to backup so went to Manage Backups.
This showed that the 6 copied files were marked as excluded and the folder had a purple tick (to show that there were exclusions within it?).
Cancelled out of this & went back in again and the folder tick has changed to green even though the six excluded files are still excluded. This would hide excluded files and could be very misleading.

Continued test by reinstating the 6 excluded files.

Ran preview again and this time I chose to exclude 3 of the 6 files but there was no option to permanently exclude them.

But there is the option to preview again before running – this does not show any of the 3 exclusions, so excluded them again and noticed that it is saying it is about to backup 6 files, so looks like nothing has been excluded.

Started the backup, and sure enough all 6 files were backed up! – ie exclusions were not actioned.

From this point on I am now plagued by the “backup is newer than indicated by the Backup Contents File” warning most times the Contents file is loaded.

I then went on to do a restore and a few other things and I've got into a state where 3 files are shown as excluded, every other file has been backed up and so there should be nothing to backup, but when I run preview, it shows the 3 excluded files (as seen via Manage Backups) as ready to be backed up!!

Haven't recreated the failure to load the contents file but it's not hard to believe that the problems seen here could act on each other to cause this under certain situations.

Good luck with this one.
Hope it's something simple.


Site Admin
Posts: 1529
Joined: Tue Aug 20, 2002 3:16 pm

Backup Newer message.

Post by Barry »

The backup newer message is owing to an update made to the last beta, it was only noticed when testing with a backlup database on a NTFS drive (FAT32 works okay). As this message is a pain; Beta build 242 version of AISBackup will be uploaded today (13 May 2005). This also includes fixes for the right click options on excluded files that Ian raised in an e-mail. This version also uninstalls AISBackup properly, there is an option to save the database, but not the activation key file (AISBackup.aik). I guess you have all got a backup of the key file anyway.

Posts: 2
Joined: Sun Aug 21, 2005 3:15 pm

Post by hackle »

Anonymity of a SOCKS Proxy. As SOCKS (as it was already marked above) transfers all data from a client to a server, nothing adding from itself, from the point of view of a web-server, a socks proxy is a client. Therefore anonymity of this type of proxy servers is very high.:
Post Reply