SMTP Authorize feature

Do you want a new option in AISBackup? Do you want an existing option enhanced? Ask here.
Post Reply
mwoplock
Posts: 17
Joined: Wed Apr 13, 2005 5:57 am
Location: Wayne, NJ (USA)
Contact:

SMTP Authorize feature

Post by mwoplock » Sun Oct 30, 2005 5:19 am

My mail server requires logging into the pop server before using the SMTP server.

Outlook has this option (change account, more settings..., outgoing server, select 'my SMTP server requires authorization', then select 'log on to my incoming mail server before sending mail')

Is there any way to add this to AIS Backup? With out it I can't set email reports.

Thanks
Mike
Mike
Appropriate Systems, LLC

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Post by Barry » Mon Oct 31, 2005 12:09 pm

AISBackup has limited support for SMTP password:

Tools / Program Options / E-Mail Settings / enter Username / enter Password / check Authentication Required.

This works okay with some of our test servers that require authentication.

If you have tried this setting then the problem may be that you require to login to the POP3 account prior to sending over SMTP, exactly as you have stated. If this is true we will prototype a version of AISBackup that does this.

Unfortunately a major re-write is required for AISBackup to support CRAM (Challenge-Response Authentication Mechanism) MD5 SASL (RFC 2195), Anonymous SASL (RFC 2245), External SASL (RFC 2222), Login, One-Time-Only-Password - OTP (RFC 2444), Plain SASL (2595), and S/Key (RFC 2222).

Barry

mwoplock
Posts: 17
Joined: Wed Apr 13, 2005 5:57 am
Location: Wayne, NJ (USA)
Contact:

Thanks for considering it

Post by mwoplock » Mon Oct 31, 2005 2:56 pm

Barry,

It sounds like there are many standards for email user authentication. I'm not in that area so I was unaware of all of the possibilities.

In my case the only way for me to use the SMTP server is to log into the pop3 server first.

I will also pursue looking for another SMTP server that I have access to that will work. Hopefully I will find a solution.

Regards,
Mike
Mike
Appropriate Systems, LLC

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Logon to POP3 first

Post by Barry » Mon Oct 31, 2005 3:08 pm

Did you have the Authentication Required setting set?

If not I will get a version with POP3 logon prior to SMTP for you to test. We do not have a server that works this way. Is yours a public SMTP server?


Barry

mwoplock
Posts: 17
Joined: Wed Apr 13, 2005 5:57 am
Location: Wayne, NJ (USA)
Contact:

SMTP Setting

Post by mwoplock » Mon Oct 31, 2005 5:16 pm

Yes, I've gone round and round with my provider. The pop3 before SMTP is a must for them. I am useing discountASP.net as my email host. The SMTP server is tied to my account.

I'm not married to using my SMTP, if you know of a good public SMTP I can use, please let me know and I will go that route. I hate to have you put a special feature in for me.

However, if you feel it is a good feature for your product I would be happy to support testing in any way. Including providing you a test email account.
Mike
Appropriate Systems, LLC

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

Send e-mail after POP logon

Post by Barry » Tue Nov 01, 2005 5:13 pm

AISBackup has been updated to optionally log on to a POP3 account prior to sending via SMTP and will be uploaded as beta 2.2 build 257 tomorrow. Perhaps you could e-mail me the details of an e-mail account so that I may test AISBackup with your SP. AISBackup assumes that SMTP and POP3 use the same account name and pasword, if this is not the case we will have to make another change.

Barry

mwoplock
Posts: 17
Joined: Wed Apr 13, 2005 5:57 am
Location: Wayne, NJ (USA)
Contact:

Post by mwoplock » Tue Nov 01, 2005 11:13 pm

Yes, the SMTP and POP use the same account name and PW. I have emailed you the UN/PW/Mail server name separately
Mike
Appropriate Systems, LLC

Barry
Site Admin
Posts: 1507
Joined: Tue Aug 20, 2002 3:16 pm

POP3 authentication

Post by Barry » Wed Nov 02, 2005 1:18 pm

The test using POP3 authentication worked okay.

Tools / Program Settings and Options / E-Mail Settings / POP Server and Logon to POP Before Sending

Barry

Post Reply