Test e-mail failed to send

Use this forum for help with AISBackup
Post Reply
Hughg
Posts:87
Joined:Sat Feb 01, 2003 11:25 pm
Test e-mail failed to send

Post by Hughg » Sun May 22, 2016 3:11 am

I'm trying to set up the email feature, but it doesn't matter whether I enter the SMTP settings manually or use the MS outlook.com or gmail settings; attempts to send a test message are greeted with the message "e-mail failed to send". Any idea where I should start looking to find a solution? I'm interested in activating the feature that sends an email if a network drive isn't connected.

Barry
Site Admin
Posts:1522
Joined:Tue Aug 20, 2002 3:16 pm

Test e-mail failed

Post by Barry » Tue May 24, 2016 11:04 am

E-mail services like Gmail require SSL encryption software is installed for AISBackup, this may be downloaded from:

http://aiscl.co.uk/ssldll.php

The latest version of AISBackup should mention the missing ssl problem within the test e-mail option, and AISBackup did give the appropriate message on a test PC here without ssl support here.

These are the settings for Gmail, except ‘emailaddress’ needs to be replaced with your own e-mail address.

Image

It may also be possible that AISBackup is being prevented from sending e-mails by the firewall. To test if this is a firewall problems try temporarily disabling the firewall for a few seconds while the test e-mail option is tried.

Barry

Hughg
Posts:87
Joined:Sat Feb 01, 2003 11:25 pm

Post by Hughg » Tue May 24, 2016 12:31 pm

Thanks, Barry. I'm running 4.2.0.458, and I do have the SSL support added in. I tried the settings you showed for Gmail with the firewall turned off, and I'm still getting the same response. Any idea what I should try next?

Barry
Site Admin
Posts:1522
Joined:Tue Aug 20, 2002 3:16 pm

Send Gmail port

Post by Barry » Tue May 24, 2016 6:23 pm

Maybe the port for sending e-mails via SMTP is different outside of the UK; indeed the Google website states:

Port for SSL:: 465 or 587

Maybe 465 will work?

They also mentioned 25 in another web page I found.

This website may help:

https://support.google.com/mail/answer/78775?hl=en

Is it possible for you to try this account in MS Outlook?

If this fails I will see if I can find out why it is failing in the code and display a more meaningful message.

Barry

Hughg
Posts:87
Joined:Sat Feb 01, 2003 11:25 pm

Post by Hughg » Sun Jun 05, 2016 7:18 pm

Sorry -- no luck with any of those settings, or with MS Outlook. The only thing I noticed was that if I tried ports 465 or 25, there was a pause of 20 seconds or so before the "e-mail failed to send" popped up, whereas with port 587 it comes up immediately.

Barry
Site Admin
Posts:1522
Joined:Tue Aug 20, 2002 3:16 pm

E-mail faling to send

Post by Barry » Mon Jun 06, 2016 9:59 am

I have uploaded a pre-release version of AISBackup that displays the error returned by the SMTP interface. The long delay you experienced was consistent with my findings when an incorrect port is used and will probably return a 'timeout' message.

http://aiscl.co.uk/aisbackupbeta.php

Barry

Hughg
Posts:87
Joined:Sat Feb 01, 2003 11:25 pm

Post by Hughg » Sun Jun 26, 2016 3:32 pm

Thanks, Barry. It turned out that google needed an app-specific password -- that's probably the case for my outlook.com account, too, because I use 2-factor authentication for both of them. I always forget about that. Perhaps AISBackup could detect a password fail and suggest to the user that it may be because they've set their account to 2-factor authentication so that they need to set an app-specific password for AISBackup?

Post Reply