Some big old files not in backup media?

Use this forum for help with AISBackup
Post Reply
brod73
Posts: 15
Joined: Tue Oct 26, 2010 9:54 am

Some big old files not in backup media?

Post by brod73 » Tue Dec 22, 2015 10:14 pm

My system info
AISBackup version number: 4.1.0.452
Windows 10 Pro x64
Backup Media: QNAP TS-219P II
Backup Source: D:\VMWare
Backup Destination: \\QNAP\Backups

My Problem
I tried to restore a backup to a given date.
The backup is configured as Advanced Session with the following params:
Each Day: 1
Daily: 7
Weekly: 5
Monthly: 12
Dated: None

When I tried to restore I 've noticed that some files do not exist.
It seems that the missing files are all large and old files (backed up and not modified long time ago). In the restore screen, for the missing files, the column Media is empty.

Screenshot of restore screen here

For example, in the screenshot, the file "OS X Mavericks.vmdk" is 40.607.169 KB size (40GB) and was backed up in session 1 (C1) but it was never removed in any session.

What does it mean the H15 in Sessions column? I see that al the missing files have a H in column session.

This backup is not critical for me, but I want to know if my other backups (very critical) are safe or if I have to reset them.

What could be the cause of the disappearance of these files?

Thanks.

Barry
Site Admin
Posts: 1508
Joined: Tue Aug 20, 2002 3:16 pm

Missing files

Post by Barry » Wed Dec 23, 2015 12:17 pm

The ‘H’ designates ‘huge’ files as they WERE back in 2001 when AISBackup was written as a backup to CD. Making backup files like this enable a file > 650 Megabytes to span over more than one CD. The huge files are still used for files over 4GB and in the case of backup to FAT32 disks 2GB. Huge files are also used in backup to FTP to enable faster recovery times in the event of a failure, however this option is not needed when backing up to FTP over a WAN.

The ‘Huge’ files use backup filenames like [Backup file name]_00064_000.AIL, where the 00064 is the number following the ‘H’ in the file list, there is a file for each split segment (The 000 is the first segment of this file). There is also a file called for example [Backup file name]_00064.aii, this holds control information and some Meta data. Details about ‘huge’ files are held in the database file [Backup name].bdb.lfn

I do not know why the backup has got corrupted on your PC and I have tested several old backups here and they are okay. It also looks that the file called ‘OS X Mavericks_Snapshot24.emem’ should be okay in your backup.
If there are files like [Backup File Name]_00015_000, [Backup File Name]_00015_001 on the backup destination then the Manage Backup / Validate (Test) Option should repair the backup. Please ensure you are running the latest version of AISBackup as work is often done on the repair option. If the missing files have not changed since the backup was taken, I guess unlikely with virtual disk files, they will be backed up during the repair process. Use the check filenames option for this to run fairly quickly. To be extra cautious make a copy of the backup first (drag and drop somewhere else), and it’s also a good idea to have more than one backup of your files in any case.

Barry

Post Reply